Error installing BoringSSL-GRPC

Стал я значится flutter разработчиком с пол года как. И вот всё было довольно неплохо, напейсал цельных два приложения и успешно разместил в апсторах и плеймаркетах. Но после обновления на flutter 2.0.1 что то при билде под iOs пошло не так. Возникла ошибка которая представлена ниже при команде pod install

[email protected] ios % pod install    
Analyzing dependencies
cloud_firestore: Using Firebase SDK version '6.33.0' defined in 'firebase_core'
firebase_auth: Using Firebase SDK version '6.33.0' defined in 'firebase_core'
firebase_core: Using Firebase SDK version '6.33.0' defined in 'firebase_core'
firebase_messaging: Using Firebase SDK version '6.33.0' defined in 'firebase_core'
Downloading dependencies
Installing BoringSSL-GRPC (0.0.7)

[!] Error installing BoringSSL-GRPC
[!] /usr/bin/git clone https://github.com/google/boringssl.git /var/folders/fb/fxsnv_l944l5mg6p859jqxnh0000gn/T/d20210306-4220-ge6hhi --template=

Cloning into '/var/folders/fb/fxsnv_l944l5mg6p859jqxnh0000gn/T/d20210306-4220-ge6hhi'...
fatal: the remote end hung up unexpectedly

Потратив изрядно времени в поисках в этих ваших интернетах нашел таки решение, оно было настолько нетривиальным что я был несколько обескуражен. В общем не хотел качаться этот боринг ссл от домашнего, проводного, быстрющего билайн интернета. Подключил к ноуту айфон в качестве модема и выполнив pod install еще разик, всё установилось.

На буржуйских форумах сказали, что вероятно всяческие постоянные блокировки безбожные всяческих айпишников нашим великими организациями типа РКН и постоянные добавления беспорядочное различных айпишников в блеклисты приводит к таким вот недоразумениям. Всем добра.

Leave a Comment